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Základy práce s ekonometrickým programom GRETL 
Martin Luká čik, Viktor Slosiar  

  

 GRETL je voľne dostupný softvérový produkt so zameraním na štatistické 

metódy podporujúci ekonometrické analýzy1. Samotný názov je akronym pre GNU 

Regression, Econometristic and Time-series Library. Jeho vznik je výsledkom spoločného 

úsilia a vedeckej činnosti niekoľkých univerzít v Spojených štátoch amerických. 

Používateľské rozhranie 

 Systém GRETL možno používať dvoma spôsobmi. Keďže snaha tvorcov systému 

od začiatku smerovala k priblíženiu ekonometrie širokej verejnosti, bolo okrem klasického 

príkazového riadku vytvorené aj grafické používateľské rozhranie (GUI – Graphical User 

Interface), ktoré je dnes pre väčšinu bežných používateľov prijateľnejšie. Po spustení 

programu sa objaví hlavné okno (Obrázok 1), kde je v hornej časti umiestnené hlavné 

menu, a v spodnej časti sa nachádza panel nástrojov. Hlavné menu obsahuje dve hlavné 

ponuky File a Tools. Ostatné sa sprístupnia v priebehu ďalších krokov. Panel nástrojov 

obsahuje praktické odkazy na najpoužívanejšie funkcie Hlavného menu, kalkulačku, návod 

na použitie a zoznam príkazov pre prácu v konzole. 

Obrázok 1: Hlavné okno programu GRETL 

 

                                                 
1 ROSENBLAD, A.: Journal of Statistical Software, Uppsala University, Marec 2008. 
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 Popri práci v GUI je tu aj možnosť práce v rozhraní s príkazovým riadkom. Do 

toho sa dá dostať po kliknutí na Tools>Gretl console v hlavnom menu, alebo cez 

panel nástrojov a tlačidlo „open gretl console“. V tomto móde sa pomocou príkazov 

vytvára syntax pre jednotlivé úlohy. Tento spôsob je oproti práci v GUI jednoduchší, ale 

vyžaduje oboznámenie sa s príkazmi. Ich úplne poznanie však nie je nevyhnutne potrebné, 

nakoľko je tu možnosť návratu do GUI, kde v paneli nástrojov tlačidlo „command 

reference“ obsahuje všetky príkazy aj s popisom. V ďalších častiach tejto práce sa budeme 

venovať používaniu programu GRETL iba v grafickom používateľskom prostredí.  

Importovanie dát 

 Získavanie ekonometrických údajov a ich spracovanie do požadovaného formátu 

pre konkrétny softvér býva často komplikované. Existuje veľa rozličných programov, ktoré 

vyžadujú vlastné autorizované formáty údajov. V tomto ohľade však GRETL ponúka 

kompatibilitu a plnú funkčnosť. Je tak možné získať prístup k veľkému množstvu 

kvalitných údajov. Navyše, dáta zo systému GRETL je možné exportovať do ďalších 

programov v požadovanom formáte.  

 GRETL už po nainštalovaní základného balíka disponuje množstvom vzorových 

údajov. Otvoriť sa dajú z hlavného menu postupom krokov File>Open data>Sample 

file. alebo priamo z panela nástrojov (Obrázok 2).  

Obrázok 2: Otváranie vzorových databáz 
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Tieto databázy možno ešte rozširovať doinštalovaním ďalších dátových súborov. 

Tie sú voľne stiahnuteľné z internetu – z oficiálnej stránky2, alebo z ďalších 

špecializovaných stránok3. Pri inštalácii ich je potrebné uložiť do základného systémového 

balíka (napr. c:\Program Files\gretl\data). Po vyhľadaní potrebnej skupiny dát 

ich stačí označiť kurzorom a otvoriť tlačidlom „open“ v hornej časti okna. Vyberať možno 

napríklad z databáz údajov Ramanathan (2002), Greene (2003), Stock and Watson (2006) 

respektíve  PoE (Hill - Principles of Econometrics, 3rd edition, 2008), ktorá bola doplnená 

zo stránky: http://www.learneconometrics.com/gretl.html. Po načítaní údajov s nimi možno 

priamo pracovať. Záložka Data, umiestnená v hlavnom menu, poskytuje veľký priestor na 

prispôsobenie štruktúry databázy podmienkam modelovania. Môžeme zobraziť, editovať, 

triediť hodnoty alebo pridávať pozorovania podľa potreby.    

Obrázok 3: Zoznam databáz 

 

 Okrem vzorových databáz je tiež možné vytvoriť vlastnú priamo v programe 

GRETL (File>New data set>...), otvoriť databázu z počítača (File>Open 

data>User file), alebo importovať v príbuznom formáte – napr. ASCII, CVS, Excel – 

(File>Open data>Import). 

To isté platí aj pri ukladaní databázy, je možné zvoliť formát v ktorom bude 

uložená podľa potreby používateľa (File>Save data as.. >> File>Export 

data>požadovaný formát) 

                                                 
2 http://gretl.sourceforge.net/gretl_data.html (2009-12-03) 
3 http://www.learneconometrics.com/gretl.html (2009-12-03) 
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Jednoduchý lineárny model s dvomi premennými 

 Prvým krokom analýzy je zabezpečenie vstupných údajov. Keďže GRETL ponúka 

veľké množstvo vzorových databáz, využijeme údaje súboru clothes.gdt zo zoznamu PoE 

(File>Open data>Sample files>PoE>clothes). Tento dátový súbor obsahuje údaje 

o počte vyrobených kusov oblečenia podniku (output of firm in clothing industry) 

a o celkových nákladoch na výrobu oblečenia (total cost of production for firm in clothing 

industry). Počet kusov oblečenia (v tis. ks) predstavuje nezávislú premennú x, celkové 

náklady (v tis. €) predstavujú závislú premennú y. Základná úloha môže preto znieť 

napríklad takto: „Ako sa zmenia celkové náklady podniku, ak dôjde k nárastu/poklesu 

výroby?“ Taktiež je zaujímavé zistiť aký silný je vzťah medzi premennými, či je tento 

vzťah priamo alebo nepriamo úmerný.  

 Niekedy je potrebné údaje prispôsobiť, aby vyhovovali podmienkam modelovania. 

To sa dá zabezpečiť kliknutím pravým tlačidlom na už vygenerovanú premennú v hlavnom 

okne. Zobrazené okno (Obrázok 4) ponúka možnosť zobrazenia hodnôt (Display values), 

ich úpravu (Edit values), meniť názov premennej (Edit attributes), pridávanie (Define new 

varieble), či zmazanie premennej (Delete). Dajú sa zobraziť popisné charakteristiky 

(descriptive statistics), čí graf boxplot pre vybranú premennú. 

Obrázok 4: Menu na úpravu údajov 

 

Grafické znázornenie dát 

 Na zobrazenie premenných x,y v súradnicovom grafe slúži tretie tlačidlo sprava na 

paneli nástrojov (Obrázok 5). Predtým je však potrebné označiť obe premenné v hlavnom 

okne. Po kliknutí na tlačidlo už stačí len zadefinovať osi pre zvolené premenné a graf sa 

vytvorí automaticky (Obrázok 6). Popis k osiam x,y sa pridáva v hlavnom okne po kliknutí 

pravým tlačidlom a výberom z menu „Edit attributes“ (Obrázok 4). 
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Obrázok 5: Tlačidlo vytvorenia grafu 

 

 

 Červené krížiky v grafe (Obrázok 6) znázorňujú jednotlivé bodové hodnoty. Modrá 

priamka je grafické znázornenie odhadu jednoduchého lineárneho modelu. Nazýva sa 

vyrovnávajúca regresná priamka. Priamka je lineárna a rastúca, to znamená, že s rastúcimi 

hodnotami premennej x rastú aj hodnoty premennej y. Zápis analytického tvaru rovnice 

y = 77,8 + 52,0x sa nachádza v ľavom hornom rohu grafu a predstavuje odhadnutý tvar 

jednoduchého lineárneho modelu. (Pozor, obvykle zapisujeme rovnicu s indexmi.) 

Obrázok 6: Grafické znázornenie premenných x a y 

 

 

Odhad parametrov modelu 

 Odhad parametrov jednoduchého lineárneho modelu yi = β0 + β1xi + ui v systéme 

GRETL sa vykoná tak, že sa označia obe premenné v hlavnom okne (premenné x a y). 

Ďalšie kroky sú nasledovné: hlavné menu>Model>Ordinary Least Squares. 

V okne, ktoré sa otvorí, je potrebné presne definovať závislú a nezávislú premennú 

(preniesť pomocou šípok z ľavej strany na pravú – Obrázok 7), potvrdiť tlačidlom OK 

a vidíme výsledok (Obrázok 8). 
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Obrázok 7: Špecifikácia modelu 

 

Stĺpec „coefficient“ označuje odhadované parametre. Prvá hodnota prislúchajúca 

riadku „const“, je odhad parametra β0 a nazýva sa lokujúca konštanta. Jej hodnota 

vyjadruje priemernú hodnotu premennej y za predpokladu, že premenná x = 0. V našom 

prípade sa dá interpretovať takto: „Za predpokladu, že sa nevyrobí ani jeden kus oblečenia, 

náklady na prevádzku podniku v priemere dosiahnu 77.795,2 €. 

Obrázok 8: Výsledná tabuľka regresného odhadu 

 

 Druhý parameter prislúchajúci riadku „x“ je odhad parametra β1 a nazýva sa 

regresný koeficient. Táto hodnota vyjadruje priemernú zmenu premennej y za predpokladu, 

že premenná x sa zmení o jednotku. Interpretácia je nasledovná: „So zvýšením výroby 

o tisíc kusov oblečenia celkové náklady podniku vzrastú v priemere o 52.009,8€.“ 
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Výsledný vzťah pre odhad lineárneho regresného modelu má tvar:   

ŷi = 77,7952 + 52,0098xi 

a je zhodný so vzťahom pre priamku v grafe na obrázku 6. Podľa tohto vzťahu sa môžu 

vytvárať prognózy. Napríklad, ak podnik vyrobí 4.500 (4,5 v tisícoch) kusov oblečenia, 

odhadované celkové náklady budú 311.839,3€ (ŷ  = 77,7952 + 52,0098*(4,5) = 311,8393). 

 Hodnota „Mean depend var“ je priemerná hodnota y. Ďalšie popisné štatistiky 

premenných sa získajú nasledovne: hlavné menu>View>Summary statistics. Zobrazí 

sa okno (Obrázok 9) s popisnými štatistikami pre jednotlivé premenné a zvolený počet 

pozorovaní („Sample“), kde vidíme priemer („Mean“), medián („Median“), minimum 

(„Minimum“), maximum („Maximum“), štandardnú odchýlku („Standard deviation“), 

variačný koeficient („C.V.“), šikmosť („Skewness“) a špicatosť („Kurtosis“). 

Obrázok 9: Popisné štatistiky premenných x a y 

 

                                                               
Odhad intervalu spoľahlivosti 

 Pri odhadovaní parametrov metódou najmenších štvorcov nás zaujíma, nakoľko je 

tento odhad presný. Najrýchlejší spôsob ako to zistiť, je priamo porovnať hodnoty 

parametrov  s odhadom ich rozptylov. Tento spôsob však nemusí odrážať reálne hodnoty, 

nakoľko je ovplyvnený výberom konkrétneho bodového odhadu. Aby sa odstránil vplyv 

náhody, vytvára sa intervalový odhad. Ten možno získať dvoma spôsobmi, a to buď 

vytvorením konfidenčného intervalu okolo hodnôt odhadu parametrov alebo testovaním 

hypotéz o parametroch β0, β1. Obe metódy sú rovnocenné. 

 Vzťah na výpočet konfidenčného intervalu má tvar: 

{ }1 11 2 1 1 2
ˆ ˆˆ ˆ 1P t tα β α ββ σ β β σ α− ≤ ≤ + = −  

kde tα/2 – kritická hodnota Studentovho rozdelenia (t) pre n - 2 stupne voľnosti, α je hladina 

významnosti, 
1

ˆβσ – odhad štandardnej odchýlky parametra 1β . 
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Na určenie hodnôt konfidenčného intervalu v systéme GRETL je potrebné mať 

odhadnutý jednoduchý lineárny model (Obrázok 8). V jeho výstupe na hornej lište cez 

ponuku „Analysis“ vyberieme „Confidence intervals for coefficients“ (Obrázok 10). 

Získame konfidenčný interval, kde sa dá cez tlačidlo α zmeniť hladina spoľahlivosti 1 – α. 

Obrázok 10: Spustenie výpočtu konfidenčného intervalu v odhadnutom modeli 

 

Hodnoty výstupu (Obrázok 11) by sa v našom prípade interpretovali napr. takto: 

„V 95 prípadoch zo 100 po navýšení výroby oblečenia o 1.000 ks náklady na výrobu 

vzrastú o viac ako 44.133,6 € a menej ako 59.886,1 €. 

{ }144,1336 59,8861 0,95P β≤ ≤ =  

Obrázok 11: Zmena hladiny spoľahlivosti pri výpočte konfidenčného intervalu 

 

 Testovanie hypotéz 

 Testovaním hypotéz získavame dôležitý záver, či nami predpokladaný vzťah alebo 

celkový lineárny model je štatisticky významný. Základom je vytvorenie hypotéz, ktoré sa 

porovnávajú. Nulová hypotéza (H0) sa porovnáva s alternatívnou (H1). Podmienkou 

štatistickej významnosti je zamietnutie nulovej hypotézy (parameter sa rovná nule). 
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 Testovanie hypotéz na vopred stanovenej hladine významnosti α je založené na 

vytvorení testovacej štatistiky, pre ktorú sú tabelované kritické hodnoty vhodných 

štatistických rozdelení. Hypotéza sa potom overuje porovnaním testovacej štatistiky 

s tabuľkovými kritickými hodnotami štatistík. 

Príklady využitia testovania štatistickej významnosti na predchádzajúcej úlohe: 

a) overenie štatistickej významnosti regresného koeficientu na hladine významnosti 0,05  

Formulácia hypotéz:   

0 1: 0H β =  

1 1 : 0H β ≠  

Kritické hodnoty sa v systéme GRETL dajú získať veľmi ľahko, a to postupom 

hlavné menu>Tools>Statistical tables (Obrázok 12). Potom stačí vybrať vhodné 

štatistické rozdelenie (v tomto prípade Studentovo rozdelenie), určiť počet stupňov 

voľnosti (df) a hodnotu α/2 (right-tail probability). Prípadnr iné údaje pre iné rozdelenia. 

Obrázok 12: Určenie kritickej hodnoty testovanej štatistiky 

 

 
Zamietnutie nulovej hypotézy sa vykoná potvrdením vzťahu 

1

1
2

ˆ 0
ˆ

tα
β

β
σ

− >  

Po dosadení odhadu regresného koeficientu a odhadu jeho rozptylu spolu s testovacou 

štatistikou do vzťahu dostaneme nasledujúci záver: 

     

Keďže nerovnosť platí, zamietame nulovú hypotézu (hodnota 13,57345 sa 

nachádza v kritickej oblasti – Obrázok 13). Regresný koeficient je štatisticky významný – 

počet vyrobených kusov oblečenia ovplyvňuje výšku celkových nákladov podniku. 
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Obrázok 13: Graf Studentovho rozdelenia pre t0,025(26) 

 

b) overenie predpokladu, že na hladine významnosti 0,05 sa so zvýšením počtu 

vyrobených kusov oblečenia o 1.000 ks, v priemere zvýšia náklady o  45.000€.  

Formulácia hypotéz:  

0 1: 45H β =  

1 1 : 45H β ≠  

Overenie hypotézy: 

1

1
2

ˆ 45
ˆ

tα
β

β
σ
− >  

 

Teda zamietame nulovú hypotézu H0, že so zvýšením výroby o 1.000 ks oblečenia 

vzrastú celkové náklady v priemere o 45.000€. 

c) overenie štatistickej významnosti modelu ako celku na hladine významnosti 0,1 

Formulácia hypotéz: 

 

 

Overenie hypotézy: 

F > F0,1(k, n – k – 1) 
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V tomto prípade sa štatistická významnosť overuje Fisherovym rozdelením. 

Kritickú hodnotu získame cez hlavné menu >Tools>Statistical tables. Zvolíme 

Fisherovo rozdelenie a po zadaní požadovaných hodnôt dostaneme F0,1(1, 26) = 2,90913. 

Vypočítaná hodnota F štatistiky je uvedená priamo vo výstupe odhadu lineárneho 

modelu a jej hodnota je v našom prípade F = 184,2391. Po dosadení do vzťahu dostaneme 

nerovnosť: 

 

Nerovnosť (tentoraz bez absolútnej hodnoty) platí, zamietame nulovú hypotézu H0, 

že regresný model nie je štatisticky významný. 

 Keďže je hladina významnosti α vždy daná vopred, ekonometrické programy 

poskytujú vo výstupe pravdepodobnostnú hodnotu (tzv. p-value). Je definovaná ako 

„najnižšia hodnota hladiny významnosti, na ktorej môžeme zamietnuť nulovú hypotézu na 

základe použitých výberových údajov.“4 Nie je tak potrebné pri každom odhadovaní 

parametrov potrebné vyhľadávať hodnoty testovacích štatistík v tabuľkách. 

 V našej úlohe má p-value hodnotu 2,61e-13 pre parameter 1̂β  a 0,0016 pre 0β̂ . 

V príkladoch a) a b) sme uvažovali na hladine významnosti α = 0,05. Nulovú hypotézu H0 

môžeme zamietnuť, ak platí p < 0,05. Táto podmienka je splnená (2,61e-13< 0,05) 

a prijímame alternatívnu hypotézu H1. Analogicky v príklade c) so zadanou hladinou 

významnosti α = 0,01 zamietame nulovú hypotézu H0 (2,61e-13< 0,01). 

 Koeficient determinácie 

 Koeficient determinácie vyjadruje akú časť variability závislej premennej vieme 

vysvetliť regresným modelom. Označuje sa R2 a v systéme GRETL sa nachádza hneď 

vo viacerých výstupoch:  

a) vo výstupe odhadu lineárneho modelu (Obrázok 14), kde je označený ako 

„R-squared“. Jeho hodnota je R2=0,876331. 

b) z analýzy rozptylu odhadnutého regresného modelu (ANOVA), ktorej výstup 

(Obrázok 15) získame, výberom záložky Analysis>ANOVA výstupe odhadu 

lineárneho modelu. Jeho hodnota je rovnaká R2=0,876331. 

Koeficient determinácie sa vypočíta nasledovne: 

2 ESS RSS
1

TSS TSS
R = = −  

                                                 
4 LUKÁČIKOVÁ, A.-LUKÁ ČIK, M.: Ekonometrické modelovanie s aplikáciami. Bratislava: EKONÓM, 
2008, str. 70. 
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kde ESS – variabilita vysvetlená regresným modelom 

RSS – variabilita nevysvetlená regresným modelom (súčet štvorcov reziduálov) 

 TSS – celková variabilita závislej premennej (TSS = RSS + ESS) 

Algebricky zapísané: 

 

 

Obrázok 14: Koeficient determinácie a výber ANOVA vo výstupe odhadu modelu 

 

 

Interpretácia koeficientu determinácie je v našej úlohe nasledovná: „Regresným 

modelom s nezávislou premennou x (počet kusov oblečenia) vieme vysvetliť 87,63% 

variability celkových nákladov podniku (závislá premenná y). Zvyšných 12,37% 

variability celkových nákladov spôsobujú činitele nezaradené do regresného modelu 

a náhodné vplyvy. 

 

Obrázok 15: Koeficient determinácie R2 z analýzy rozptylu ANOVA 
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Lineárny model s viacerými premennými 

 Odhad lineárneho modelu a ďalšie postupy sú podobné odhadu modelu s dvomi 

premennými. V lineárnom modeli s viacerými premennými sa vyžaduje podmienka, aby 

žiadna nezávislá premenná nebola lineárnou kombináciou iných nezávislých premenných. 

 Základy si ukážeme na údajoch súboru andy.gdt (hlavné menu>File>Open 

data>Sample file>PoE>andy). Tento súbor obsahuje tri premenné: mesačné zisky 

z predaja S (v tis. €), predajnú cenu produktu P (v €) a náklady na reklamu A (v tis. €). 

Závislou (vysvetľovanou) premennou yi bude zisk z predaja, na ktorý vplýva predajná cena 

produktu (premenná xi1) a náklady na reklamu (premenná xi2). Lineárny model má tvar: 

0 1 1 2 2i i i iy x x uβ β β= + + +  

Na odhad parametrov použijeme metódu najmenších štvorcov a získame model: 

0 1 1 2 2
ˆ ˆ ˆˆi i iy x xβ β β= + + , 

kde ŷi je vysvetľovaná premenná a 0 1 2
ˆ ˆ ˆ,  a β β β  sú odhadnuté parametre. 

 V systéme GRETL sa odhad modelu s viacerými premennými líši oproti odhadu 

jednoduchého lineárneho modelu iba tým, že pri definovaní modelu je potrebné do časti 

pre nezávislé premenné presunúť všetky potrebné nezávislé premenné. 

Obrázok 16: Výstup odhadu lineárneho modelu s tromi premennými 

 

 Odhadnutý model má tvar: 

îs  = 118,914 – 7,90785pi + 1,86258ai 

a vieme odhadnúť vplyv zmeny nezávislých premenných na závislú. Napríklad, s nárastom 

ceny produktu o jedno euro pri nezmenených nákladoch na reklamu, sa celkové mesačné 

zisky znížia v priemere o 7.907,85 €. Ak náklady na reklamu vzrastú o jednotku (1.000 €) 

pri nezmenenej cene, celkové mesačné zisky sa v priemere zvýšia o 1.862,58 €.  
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 Môžeme takto modelovať rôzne situácie, napríklad vieme odhadnúť priemerný 

mesačný zisk za predpokladu, že cena produktu bude 5,5 € a mesačné náklady na reklamu 

budú 800 €: 

îs = 118,914 – 7,90785(5,5) + 1,86258(0,8) = 76,910889 

Mesačný zisk za hore uvedených predpokladov dosiahne hodnotu v priemere 76.910,89 €. 

Určenie konfidenčných intervalov je analogické ako pri jednoduchom lineárnom 

regresnom modeli. 

Výstup regresie ponúka aj množstvo ďalších štatistických údajov. Štandardné 

odchýlky parametrov lineárneho modelu sú uvedené v stĺpci „std. error“. Ďalšie údaje 

vieme získať analýzou rozptylu ANOVA, ich využitie je rovnaké ako bolo uvedené 

v druhej kapitole. Napríklad na určenie koeficientu determinácie R2, ktorého hodnota 

R2 = 0,448258 vyjadruje fakt, že pomocou premenných xi1 a xi2 vieme vysvetliť 44,83% 

variability mesačných ziskov (yi). 

Pridávaním nezávislých premenných do modelu dochádza k zníženiu hodnoty 

celkovej variability reziduálov (ESS) a k zvýšeniu hodnoty koeficientu determinácie R2. 

Hodnota R2-adjusted = 0,432932 koriguje takto vzniknutý rozdiel. 

Testovanie združenej hypotézy (F-test) 

 Test združenej hypotézy o parametroch modelu sa používa, keď hypotéza obsahuje 

predpoklady s viacerými znakmi porovnania. Ak je hodnota F štatistiky väčšia ako 

tabuľková hodnota Fisherovho rozdelenia, zamietame nulovú hypotézu: 

( )
( ) ( ) 0, 1 zamietame 

1
R U

U

RSS RSS q
F F q n k H

RSS n k

−
= > − − →

− −
 

q – počet testovaných hypotéz (znakov porovnania). Indexy R a U označujú modely. 

V našej modelovej úlohe sa budeme zaoberať testovaním hypotézy, či má cena 

produktu vplyv na celkový mesačný zisk. Nulová hypotéza H0 bude predstavovať 

možnosť, že vplyv nemá, alternatívna hypotéza H1 bude predstavovať možnosť, že má. 

0 1 0 2 2: 0    model  má tvar:   i i iH R y x uβ β β= = + +  

           1 1 0 1 1 2 2: 0    model  má tvar:   i i i iH U y x x uβ β β β≠ = + + +  

V systéme GRETL sa takáto úloha rieši nasledovne: vo výstupe odhadu modelu 

vyberieme  ponuku „Tests“. Z nej sa testovania hypotéz týkajú prvé štyri možnosti 

(Obrázok 17) – a to vynechať premenné (Omit variables) v nulovej hypotéze H0, pridať 

premenné (Add variables) v alternatívnej hypotéze H1, testovanie súčtu  koeficientov (Sum 

of coefficients) alebo testovanie ľubovoľného lineárneho obmedzenia (Linear restrictions).  
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Obrázok 17: Možnosti testovania hypotéz vo výstupe odhadu modelu 

 

 V našom prípade chceme zistiť, či má na mesačný zisk vplyv cena produktu. 

Využijeme preto možnosť „Omit variables“. V zobrazenom dialógovom okne vyberieme 

premenné, ktoré chceme odstrániť z modelu (v našom prípade cenu P) t.j. o výbere 

možností odhadu necháme označenú možnosť „Estimate reduced model“ (príp. Waldov 

test ale v tomto prípade sa neodhadne redukovaný model) a potvrdíme tlačidlom OK. 

Zobrazí sa nám výstup modelu R (Obrázok 18), kde v spodnej časti sú vypočítané hodnoty 

pre  F(1, 72) = 52,0597 a  p-value = 4,424e-10. 

 Rovnaký výsledok dostaneme aj použitím lineárneho ohraničenia „Linear 

restrictions“. V dialógovom okne lineárnej reštrikcie ho musíme špecifikovať. Chceme 

vylúčiť premennú P z modelu, preto sa jej parameter musí rovnať nule. V dialógovom 

okne sa to zapíše nasledovne: b[2]=0, kde 2 je poradové číslo parametra v modeli. Po 

potvrdení OK sa zobrazí výstup s rovnakými hodnotami F a p-value ako v prvom spôsobe. 

Obrázok 18: Odhad modelu s ohraničením (model R) 

 

      52,05969 > 3,9739  

Keďže nerovnosť platí, na hladine významnosti 0,05 zamietame nulovú hypotézu, 

že cena produktu nemá vplyv na celkový mesačný zisk. 



 
 

16 

Nesplnenie základných predpokladov modelu 

 Lineárny model musí spĺňať viaceré predpoklady, na základe ktorých je odhad 

modelu metódou najmenších štvorcov neskreslený a efektívny. Doteraz sme sa v texte 

stretli s podmienkou o lineárnej nezávislosti vysvetľujúcich premenných (nesplnenie tejto 

podmienky sa nazýva multikolinearita). Pri definícii náhodnej zložky ui sa predpokladá, že 

priemerná hodnota náhodnej chyby je pre každú hodnotu nezávislej premennej xik nulová. 

Teda E(ui) = 0; i = 1,2,3,...,n. Zjednodušene by sa dalo povedať, že vplyvy nezahrnuté do 

modelu pôsobia navzájom protichodne a rušia sa.  V tejto časti sa budeme podrobnejšie 

zaoberať ďalšími tzv. základnými predpokladmi lineárneho regresného modelu. 

Heteroskedasticita 

 Ďalším predpokladom lineárneho modelu je rovnaká hodnota rozptylov náhodnej 

zložky ui pre rôzne hodnoty vysvetľujúcej premennej xik. Označuje sa ako podmienka 

o homoskedasticite lineárneho modelu a jej algebrický zápis je nasledovný: 

( ) 2 2var | | konštantai i i iu x E u x σ = = =   

 V prípade, že hodnoty rozptylov nie sú rovnaké, dochádza k nesplneniu 

homoskedasticity a nastáva jav označovaný ako heteroskedasticita5. V takýchto prípadoch 

sa výsledky odhadu modelu bez zohľadnenia tejto poruchy nedajú overiť, lebo štatistické 

testy sú neadekvátne. Boli preto vypracované postupy detekcie heteroskedasticity a metódy 

výpočtu želaných výstupov v takomto modeli bez problémov s indukčnými závermi. 

Heteroskedasticita je typická najmä v súbore prierezových údajov, kde je výrazná 

heterogenita štruktúry skúmaných údajov. Potom platí: 

( ) 2 2var | | i i i i iu x E u x σ = =   

To znamená, že rozptyl náhodnej zložky 2
iσ  je závislý od konkrétneho pozorovania i. 

Testovanie heteroskedasticity  

V niektorých prípadoch už samotná povaha problému napovedá, že sa v danom 

modeli sa bude vyskytovať heteroskedasticita. Sú to napríklad súbory obsahujúce údaje 

typu príjmy – výdavky. Z viacerých metód testovania vysvetlíme na Whitovom teste.  

V dialógovom okne odhadnutého modelu vyberieme z ponuky v hornej lište 

možnosť Tests>Heteroskedasticity>White’s test. Ak si zvolíme príklad modelu 

s dvomi premennými, dostaneme výstup na obrázku 19. 

                                                 
5 LUKÁČIKOVÁ, A.-LUKÁ ČIK, M.: Ekonometrické modelovanie s aplikáciami. Bratislava: EKONÓM, 
2008, str. 139. 
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 Princíp Whitovho testu spočíva vo výpočte hodnoty štvorcov reziduálov  pre 

každé pozorovanie a odhadnutí parametrov pomocnej regresie, pre ktorú sa vypočíta 

koeficient determinácie R2. Testovacia štatistika má potom tvar WH=nR2. 

 Samotný test je založený na porovnaní testovacej štatistiky WH s kritickými 

hodnotami -rozdelenia, v ktorom sa počet stupňov voľnosti c rovná počtu 

vysvetľujúcich premenných pomocnej regresie. 

 

Obrázok 19: Whiteov test heteroskedasticity 

 

Výstup obsahuje údaje pomocnej regresie a hodnotu koeficientu determinácie , 

pomocou ktorého je vypočítaná testovacia štatistika: 

 

 

Keďže nerovnosť platí, na hladine významnosti 0,05 zamietame nulovú hypotézu, 

že v modeli nie je prítomná heteroskedasticita. 

Autokorelácia 

 Ďalším základným predpokladom lineárneho regresného modelu sú navzájom 

nekorelované náhodné zložky. To znamená, že náhodné zložky z dvoch ľubovoľných 

pozorovaní musia byť nezávislé. Algebricky zapísané: 

( )cov , | , 0, pre 0t t s t t su u x x s+ + = > . 

 Nesplnenie tejto podmienky sa nazýva autokorelácia6 a je typická pre modely 

časových radov. 

                                                 
6 LUKÁČIKOVÁ, A.-LUKÁ ČIK, M.: Ekonometrické modelovanie s aplikáciami. Bratislava: EKONÓM, 
2008, str. 205 
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 Medzi hlavné príčiny výskytu autokorelácie v časových radoch ekonomických 

údajov patrí zotrvačnosť údajov (nevysvetlenie zmeny údajov závislej premennej 

vysvetľujúcimi premennými), nesprávna špecifikácia modelu a úprava údajov, ktorá 

predchádzajúca ich analýze. 

Testovanie autokorelácie 

 Podobne ako pri testovaní heteroskedasticity, aj pri testovaní autokorelácie bolo 

vypracovaných viacero metód testovania. Najpoužívanejšou sa však stal Durbin-Watsonov 

test, aj keď je testom autokorelácie iba 1. rádu. Hypotézy majú tvar: 

 

 

kde ρ je korelačný koeficient. Testovacia štatistika má tvar: 

( )2

1
2

2
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n

t t
t
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kde ei sú reziduály získané z odhadu metódou najmenších štvorcov. Test pozostáva 

z porovnania testovacej štatistiky s tabuľkovou hodnotou. V nej na zvolenej hladine 

významnosti pre k nezávislých premenných a n pozorovaní dostaneme hornú kritickú 

hodnotu dU a dolnú kritickú hodnotu dL. O prijatí alebo zamietnutí danej hypotézy potom 

rozhodujú nasledujúce podmienky: 

 

 

 

Ak  na základe porovnania testovacej štatistiky a tabuľkových hodnôt zamietneme 

nulovú hypotézu , v modeli je vysoko-pravdepodobná prítomnosť pozitívnej 

alebo negatívnej autokorelácie 1. rádu. 

 V našom prípade pre ukážku využijeme súbor inflation.gdt (hlavné menu>Open 

data>Sample file>PoE). Ďalej je potrebné si prispôsobiť tieto údaje,lebo je dôležité 

definovať dátový súbor ako časový rad. Postup je nasledovný: hlavné menu>Dataset 

structure. Otvorí sa dialógové okno „Dataset structure wizard – Structure of dataset“, 

kde označíme možnosť časové rady „Time series“ a potvrdíme tlačidlom „Forward“. 

V ďalšom okne označíme frekvenciu sledovaných údajov (mesačná) a potvrdíme tlačidlom 

„Forward“. Nasleduje určenie počiatku sledovania v novom zobrazenom okne a posledný 

krok je potvrdenie celého nastavenia tlačidlom „Apply“. 
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 Keď máme dáta upravené, môžeme pristúpiť k odhadnutiu lineárneho modelu 

a k samotnému testovaniu prítomnosti korelácie. Odhad modelu sa uskutoční analogicky 

ako už bolo prezentované (zoznam premenných modelu je zrejmý z obrázka 20). 

Obrázok 20: Výstup odhadu lineárneho modelu s časovými radmi 

 

 

V odhadnutom modeli slúži na odhalenie prítomnosti autokorelácie korelogram 

reziduálov. Je to graf zaznamenávajúci korelácie medzi reziduálmi odhadnutého modelu. 

V okne výstupu odhadu lineárneho modelu (Obrázok 20) zvolíme „Graphs“ a vyberieme 

možnosť „Residual correlogram“. Určíme potrebný počet oneskorení reziduálov (lag) 

a potvrdíme tlačidlom OK. GRETL vytvorí výstup v tabuľkovej aj grafickej podobe. 

Obrázok 21: Korelogram reziduálov v tabuľkovej forme. 
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Hodnota ACF označuje hodnotu výberovej autokorelačnej funkcie a hodnota PACF 

hodnotu výberovej parciálnej autokorelačnej funkcie. Na grafe sú hodnoty potvrdzujúce 

autokoreláciu tie, ktoré prekračujú hranice naznačenej priamky. Sú to tie isté, ktoré 

v tabuľkovom korelograme označujú aspoň 2 hviezdičky. 

 Testovanie autokorelácie v odhadnutom lineárnom modeli je možné aj testom 

Lagrangeových multiplikátorov – v ponuke „Tests“ odhadu lineárneho regresného modelu 

vyberieme možnosť „Autocorrelation“. Určíme počet oneskorení (lag) a potvrdíme. 

Obrázok 22: Test Lagrangeových multiplikátorov 

 

 Vo výstupe je vypočítaných viacero testovacích štatistík, ktoré po porovnaní 

s tabuľkovou hodnotou rozdelení. Všetky na hladine významnosti 0,05 potvrdzujú 

prítomnosť autokorelácie v modeli. 

Prognóza hodnôt závislej premennej 

 Prognózovanie a modelovanie nasledujúceho vývoja skúmaných javov je jednou zo 

základných aplikácií ekonometrického modelu. V našom prípade chceme odhadnúť, aké 
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hodnoty bude nadobúdať inflácia v nasledujúcich troch mesiacoch. Postupujeme ako pri 

odhade lineárneho modelu (hlavné menu>Model>Ordinary Least Squares), pričom 

zadáme závislú premennú, ktorej sa týka prognóza. Nezávislými premennými v prvom 

modeli budú iba oneskorené premenné. Keďže sme na začiatku údaje špecifikovali ako 

rad, v spodnej časti okna sa pridalo tlačidlo „ lags...“. Po kliknutí naň v dialógovom okne 

potvrdíme, že odhadujeme závislú premennú infln a určíme počet jej oneskorení 

(Obrázok 23). Po potvrdení sa do okna špecifikácie modelu pridajú tri premenné (infln(-1), 

infln(-2), infln(-3)), pomocou ktorých budeme prognózovať. Potvrdíme tlačidlom OK 

a máme odhad modelu pre premennú infln spolu s oneskorenými premennými. 

Obrázok 23: Doplnenie oneskorených premenných do modelu 

  

  

Po tejto jednoduchšej prognóze si ukážeme, že prognózovať sa dá aj v modeloch 

s vysvetľujúcimi premennými, kde nie sú iba oneskorené závislé premenné, ale vtedy 

musíme najskôr predĺžiť rozsah údajov. Následne musíme získať prognózu vysvetľujúcich 

premenných a doplniť ju medzi údaje. Ďalší postup je zhodný s tým, ktorý uvádzame.                      
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Obrázok 24: Odhad lineárneho regresného modelu s oneskorenými premennými 

 

  

Po odhade modelu môžeme pristúpiť k samotnej prognóze: v hornej lište ponuky 

vyberieme záložku „Analysis“ a v nej možnosť „Forecasts..“. Otvorí sa nám okno, 

v ktorom sa určí rozsah odhadu – posledná hodnota inflácie je z 2006:04 a my potrebujeme 

prognózu na nasledujúce tri mesiace takže do okna „Forrecast range“ zadáme hodnotu 

2006:05 a 2006:07. Ďalej označíme, že vytvárame automatickú predpoveď, zadáme počet 

pozorovaní zobrazených na grafe (100) a na záver určíme spoľahlivosť odhadu (0,95%). 

 

Obrázok 25: Špecifikácia prognózy 
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Obrázok 26: Prognóza inflácie na mesiace 05/2006 až 07/2006 

 

 
 Prognóza získaná takýmto jednoduchým autoregresným modelom nie je v tomto 

prípade príliš vhodná, aj keď by mohla prípadne vyjsť. Tento záver potvrdzuje aj graf. 

Obrázok 27: Graf vývoja inflácie v rokoch 1998 – 2006 s pridanou prognózou 

 

 
 Prv ako vytvoríme prognózu pomocou modelu s vysvetľujúcimi premennými, kde 

nie sú iba oneskorené závislé premenné, nájdeme vhodný model. Nám sa pozdával ako 

vhodný autoregresný model s rozloženým oneskorením na obrázku 28. 



 
 

24 

Obrázok 28: Model pre prognózu s vysvetľujúcimi premennými 

 

Najskôr musíme predĺžiť rozsah údajov pomocou ponuky hlavné menu>Data>Add 

observations… zobrazenej na obrázku 29. 

Obrázok 29: Rozšírenie počtu pozorovaní o tri, po august 2006 

 

Následne doplníme rad hodnôt vysvetľujúcich premenných o prognózované 

hodnoty pre obdobia o ktoré bol rozšírený dátový súbor (Obrázok 30).  

Obrázok 30: Vysvetľujúca premenná doplnená o 3 údaje potrebné pre prognózu 

 

Ďalší postup sme už realizovali, teda špecifikujeme prognózu podľa obrázku 25. 

Výsledok prognózy závisiaci od hodnôt z obrázka 30 vidíme zobrazený na obrázku 31. 
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Obrázok 31: Výsledok prognózy 
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